Bug 11247

GemStone/S

6.7, 6.6.5, 6.6.4, 6.6.3.3, 6.6.3.2, 6.6.3, 6.6.2, 6.6.1, 6.6, 6.5.8, 6.5.7.5, 6.5.7, 6.5.6, 6.5.5, 6.5.4, 6.5.2, 6.5.1, 6.5, 6.3.1, 6.3, 6.2.x, 6.2, 6.1.6, 6.1.5, 6.1.x, 6.0.x, 5.1.5.1, 5.1.5, earlier versions

Unix

The gemsetup.sh and gemsetup.csh scripts set path incorrectly

Gemsetup.sh and gemsetup.csh are both scripts which can be used
to select the GemStone version.  However, when you use these scripts,
they put the GemStone version at the end of the current path.
As a result, when you attempt to execute 'startstone',
'startnetldi', or 'topaz', you will get the old version instead
of the new version.

Workaround

Make sure there are no other GemStone installations in your path
when you use gemsetup.


Last updated: 11/14/07