Bug 48879

GemStone/S 64 Bit

3.5.4, 3.5.3

3.6, 3.5.5

Cross-version external sessions limited to specific other versions

GsTsExternalSession allows you to start an external session against a Stone running a different version of GemStone. This feature requires that the other version also support the cross-version login feature.

The version verification in 3.5.3 and 3.5.4 was limited and will fail for later versions (e.g., against a 3.5.5 stone).

Also note that the version requires exactly '3.6.0', and does not accept '3.6'.

Workaround

We recommend upgrading to 3.5.5 or later to use cross-version external sessions.

For testing, you may login as SystemUser and edit GciTsLibrary >> version:


Last updated: 2/12/21