Bug 48599

Informational

GemConnect

2.4

Solaris/SPARC

GemConnect 2.4 on Solaris/SPARC requires SUNW_1.22.7 (Solaris version 11)

GemConnect 2.4 requires Oracle version 12 and on Solaris/SPARC, Oracle 12 requires libc.so version SUNW_1.22.7, available on Solaris version 11.  Using an earlier version of Solaris will trigger the following error when attempting to load the liboraapi24-643.so library:

Error 2171 , a ImproperOperation occurred (error 2171), user action library load  failed, 'GciLoadUserActionLibrary failed, dlopen failed, ld.so.1: topaz: fatal:  libc.so.1: open failed: No such file or directory; Filename: $GEMSTONE/ualib/liboraapi24-643.so' (ImproperOperation)

Note that Solaris/SPARC is no longer a supported platform for GemStone/S 64 Bit.

Workaround

Only use on Solaris/SPARC version 11 or later.


Last updated: 3/13/20