Bug 45566

GemStone/S 64 Bit

3.3.7, 3.3.6, 3.3.5, 3.3.4, 3.3.3, 3.3.1, 3.3, 3.2.16, 3.2.15, 3.2.14, 3.2.13, 3.2.12, 3.2.11, 3.2.10, 3.2.9, 3.2.8.1, 3.2.8, 3.2.7, 3.2.6, 3.2.5

Linux SUSE 11

SUSE 11 using older glibc; LDAP not usable

As of version 3.2.5, GemStone was compiled on a platform using glibc version 2.12.  However, SUSE v11 sp3 uses an older version of glibc, v2.11.  The GemStone LDAP libraries have a dependency on a symbol in glibc v2.12; attempting to load the LDAP libraries on a system using glibc v2.11 encounters a library load error.

As a result, LDAP is not usable on SLES 11SP3 with glibc 2.11.x.  We believe that this is the only issue caused by the older glibc version; our tests have shown no other issues.

SLES 11 has been removed from the list of certified platforms.


Last updated: 8/20/15